cyb3rpunk

Instalar Warzone 2100 en Debian

Posted in Debian, Tutorial, Videojuegos by ramonovski on mayo 18, 2009

Me tomó unas cuantas horas instalarlo; entre buscando y leyendo información, bajando paquetes, viendo el futbol, tocando la guitarra y chateando.

Primero hay que bajarnos el source desde su página oficial.

Antes de empezar a compilar tenemos que tener todos estos paquetes instalados:

bison diffstat flex libaa1-dev libartsc0-dev libasound2-dev libaudio-dev libaudiofile-dev libcaca-dev libcucul-dev libdirectfb-dev libesd0-dev libfreetype6-dev libgl1-mesa-dev libgl1-mesa-dri libglib2.0-dev libglu1-mesa-dev libglu1-xorg-dev libice-dev libjpeg62-dev libmad0-dev libmpeg3-1 libmpeg3-dev libogg-dev libopenal-dev libopenal0a libphysfs-1.0-0 libphysfs-dev libpng12-dev libpopt-dev libsdl-net1.2 libsdl-net1.2-dev libsdl1.2-dev libslang2-dev libsm-dev libsvga1-dev libvorbis-dev libxt-dev mesa-common-dev quilt zlib1g-dev

Ahora si, descomprimir el archivo de warzone2100 y compilar con los 3 comandos mágicos:

# ./configure
# make
# make install

Si por alguna razón nos marca un error con alguna librería de openGLC al ejecutar ./configure, entonces nos bajamos el archivo QuesoGLC (ríete Pato) desde este link: http://sourceforge.net/project/showfiles.php?group_id=53918&package_id=58469

Descomprimimos y compilamos:
# ./configure
# make
# make install

Y muy importante ejecutar en consola # ldconfig para actualizar las librerias recien instaladas.

Ahora si, compilar normalmente el archivo de warzone 2100 y listo!

Si, creo haber leido que hay un .deb por ahi en getdeb pero no lo probé… me gusta batallar xD!

About these ads

12 comentarios

Suscríbete a los comentarios mediante RSS.

  1. Davidorum said, on junio 12, 2009 at 11:19 am

    Pues lo que no consigo instalar yo es el QuesoGLC ese… al hacer “./configure” me dice “configure: error: GLU library not found” estoy buscando dónde bajar la biblioteca esa pero de momento nada.

    Seguiremos informando

  2. Teh said, on junio 12, 2009 at 7:52 pm

    Instalaste libglu1-mesa-dev y libglu1-xorg-dev como lo cité arriba?

    • Davidorum said, on junio 13, 2009 at 12:23 am

      Sí, acabo de comprobarlo porque instalé todos los paquetes de golpe. El único paquete que me dio problemas fue “libartsc0-dev”. El sistema de dice que no puede encontrarlo. Se me olvidó comentar que utilizo Xubuntu 9.04 y no Debian porque no soy precisamente un experto en esto de Linuxr.

      ¡Gracias por tu respuesta!

  3. luis said, on septiembre 25, 2009 at 10:11 am

    hermano dime donde esta mi herror:

    luis@primera:~/Escritorio/warzone2100-2.2.3$ ./configure
    checking for a BSD-compatible install… /usr/bin/install -c
    checking whether build environment is sane… yes
    checking for a thread-safe mkdir -p… /bin/mkdir -p
    checking for gawk… no
    checking for mawk… mawk
    checking whether make sets $(MAKE)… yes
    checking build system type… i686-pc-linux-gnu
    checking host system type… i686-pc-linux-gnu
    checking for style of include used by make… GNU
    checking for gcc… gcc
    checking for C compiler default output file name… a.out
    checking whether the C compiler works… yes
    checking whether we are cross compiling… no
    checking for suffix of executables…
    checking for suffix of object files… o
    checking whether we are using the GNU C compiler… yes
    checking whether gcc accepts -g… yes
    checking for gcc option to accept ISO C89… none needed
    checking dependency style of gcc… gcc3
    checking for gcc option to accept ISO C99… -std=gnu99
    checking for gcc -std=gnu99 option to accept ISO Standard C… (cached) -std=gnu99
    checking for ranlib… ranlib
    checking for g++… g++
    checking whether we are using the GNU C++ compiler… yes
    checking whether g++ accepts -g… yes
    checking dependency style of g++… gcc3
    checking for bison… bison -y
    checking for bison >= 1.31… found 2.3, ok
    checking for flex… flex
    checking lex output file root… lex.yy
    checking lex library… -lfl
    checking whether yytext is a pointer… yes
    checking for flex >= 2.5.33… found 2.5.35, ok
    checking for flex != 2.5.34… not found, good
    checking whether perl executable path has been provided… no
    checking for perl… /usr/bin/perl
    checking for a sed that does not truncate output… /bin/sed
    checking for grep that handles long lines and -e… /bin/grep
    checking for perl version… 5.10.0
    checking for gawk… (cached) mawk
    checking how to run the C preprocessor… gcc -std=gnu99 -E
    checking for egrep… /bin/grep -E
    checking for ANSI C header files… yes
    checking for sys/types.h… yes
    checking for sys/stat.h… yes
    checking for stdlib.h… yes
    checking for string.h… yes
    checking for memory.h… yes
    checking for strings.h… yes
    checking for inttypes.h… yes
    checking for stdint.h… yes
    checking for unistd.h… yes
    checking minix/config.h usability… no
    checking minix/config.h presence… no
    checking for minix/config.h… no
    checking whether it is safe to define __EXTENSIONS__… yes
    checking for strlcpy… no
    checking for strlcat… no
    checking alloca.h usability… yes
    checking alloca.h presence… yes
    checking for alloca.h… yes
    checking whether NLS is requested… yes
    checking for msgfmt… no
    checking for gmsgfmt… :
    checking for xgettext… no
    checking for msgmerge… no
    checking for ld used by GCC… /usr/bin/ld
    checking if the linker (/usr/bin/ld) is GNU ld… yes
    checking for shared library run path origin… done
    checking for CFPreferencesCopyAppValue… no
    checking for CFLocaleCopyCurrent… no
    checking for GNU gettext in libc… yes
    checking whether to use NLS… yes
    checking where the gettext function comes from… libc
    ./configure: line 8969: msgfmt: command not found
    checking for msgfmt >= 0.15… ./configure: line 8987: [: : integer expression expected
    ./configure: line 8989: [: : integer expression expected
    found , ok
    ./configure: line 8969: xgettext: command not found
    checking for xgettext >= 0.15… ./configure: line 8987: [: : integer expression expected
    ./configure: line 8989: [: : integer expression expected
    found , ok
    checking for pkg-config… /usr/bin/pkg-config
    checking pkg-config is at least version 0.9.0… yes
    checking for pkg-config >= 0.9… found 0.22, ok
    checking whether to build NSIS installer… no
    checking whether to compile in debug mode… no
    checking for SDL… configure: error: Package requirements (sdl >= 1.2) were not met:

    No package ‘sdl’ found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables SDL_CFLAGS
    and SDL_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.

    • Teh said, on septiembre 26, 2009 at 1:01 am

      Verifica que tengas el paquete de SDL instalado, puedes probar tambien con ‘SDL-devel’.

  4. Emerling said, on febrero 19, 2010 at 8:53 pm

    yo por synaptic busque lo que decia libsdl marque varios y siguio, pero se me paro en algo que se llama tehora y alli sino lo consigo por synaptic

  5. Emerling said, on febrero 19, 2010 at 9:20 pm

    correcion si paso con libtheora, creo que simplemente hay que ir buscando cada dependencia tal como sale arriba, uno por uno en mi caso, pero, algunos aun n doy con ellos, solo trato de deducir segun el mensaje decia algo de lib y theora y sas busque libtheora y estaba alli

  6. Emerling said, on febrero 19, 2010 at 9:29 pm

    el glc buscalo en synaptic. yo cooque glc y marque sy sigue peorsdespues de pasar todo las libreria escribi make, y realizo cualqueir cantidadevaias, al final decia algo de saliendo de directorio y en el make instala hizo algo semejante pero se instalo ahora lo pruebo, mi recomendacion cuando te diga algo como el sdl buscalo precediendo lib en synaptic asi fue que fui logrando las dependencias.

  7. juanitoperez said, on marzo 9, 2010 at 3:58 pm

    holas
    tengo un problema con el ./configure :
    me dice que no encuentra la libreria openGL32 y la he buscado por todos lados … de hecho instale todas las librerias que citaste arriba y las q salen en la pagina de warzone (las tuyas estan mas completas) pero nada ….. las tengo todas y no pasa nada (creo q las librerias libopenl y libopenl0a no las encuentra) incluso tengo instalado “queso”

    si las librerias que faltan son esas …. me podrias decir de donde las sacaste??? …. si no es eso …. me ayudas a buscar una solucion?????

    muchas gracias por todo

    • Teh said, on marzo 9, 2010 at 8:16 pm

      Dime que distro usas.

      Tal vez te sirva mejor el paquete .deb, en caso de usar Deb y derivados.

  8. fabio said, on diciembre 14, 2010 at 10:56 pm

    hola tengo problemas cuando ejecuto ./configure y make en quesoglc,creo que son las dependecias,me podrias ayudar. como lo hiciste vos? uso debian lenny gracias.


Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Seguir

Recibe cada nueva publicación en tu buzón de correo electrónico.

%d personas les gusta esto: